The issue with workspace visibility in Roo Code Cloud has been resolved. Impact was limited to folder names and short message snippets being briefly visible to other users. Full conversations were never exposed, and no unauthorized actions were possible. We’ve hardened our systems to prevent this from happening again.
Posted Sep 14, 2025 - 19:04 PDT
Monitoring
We have deployed a fix that removes the incorrect assumption about session IDs and added additional safeguards. The Roomote Control feature has been re-enabled, and we are monitoring closely to ensure the issue does not recur.
Posted Sep 13, 2025 - 15:43 PDT
Identified
We have identified the root cause: our system relied on an identifier (vscode.env.sessionId) that was not guaranteed to be globally unique. This caused some users to briefly see workspace names and short message snippets from other accounts. Full conversations were not exposed, and there was no ability to send messages. Roomote Control remains disabled while we work on a fix.
Posted Sep 12, 2025 - 10:00 PDT
Investigating
We are currently investigating an issue where some users may see unexpected workspaces in their Roo Code Cloud account. The Roomote Control feature has been disabled while we investigate further.